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Setup 
This section will guide you through the process of installing the 

Corrosion Data Management Software on your PC.  Before 

installation, make sure that you have read and accepted the License 

Agreement found in the back of this manual. 

 

System Requirements 

To run the Corrosion Data Management Software, you need a PC 

that meets the following requirements: 

 

 Pentium® class processor 

 Windows® XP, Vista, Windows 7, Windows 8, and 

Windows 10, 32- or 64-bit operating systems 

 16 MB of RAM 

 10 MB of available hard-disk space 

 VGA monitor with 800  600 or greater resolution 

 Mouse or pointing device recommended 

 Available 9-pin RS-232 serial port or USB port for 

instrument download 

 

Installing The Software 
To install the Corrosion Data Management Software: 

 

1. Uninstall any previous installations of the software. 

2. Browse to the folder or drive containing the installation 

package. 

3. Select and run “setup.exe”.  This will launch the 

installation program. 

 

 
 

4. You may change the directory that will contain the 

software by clicking the Change Directory button.  To 

install the software in the default directory, click the 

Install button. 
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5. After clicking the Install button, follow the on-screen 

prompts to complete the software installation. 

6. If you are prompted regarding existing files, select the 

option to keep the newer file(s).  

 

Uninstalling The Software 
If it is necessary to uninstall the CDMS software, this can be done 

from the Windows control panel.  The specific steps will depend 

on which version of Windows you have. 
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Introduction 

Metal Samples Corrosion Data Management Software (CDMS) is 

a collection of utilities designed to assist the corrosion analyst in 

gathering and analyzing corrosion data.  It includes tools for 

downloading and charting data from Metal Samples data loggers, 

calculating LPR alloy multipliers for 2-electrode probes, and for 

calculating corrosion rate from corrosion coupons. 

 

The Main Menu can be used to launch all of the utilities of the 

CDMS package.  To close the program, click the EXIT button at 

the bottom of the Main Menu. 
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Instrument Download Center 
 

The Instrument Download Center is a simple tool for retrieving 

data from Metal Samples ER and LPR data logger instruments.   

 

 
 

To download data from an instrument: 
 

 Connect the instrument to an available PC serial port (see 

the instrument manual) 

 Run the Corrosion Data Management Software 

 Open the Instrument Download Center 

 Select the serial port and instrument 

 Click the Download button 

 Select the computer upload function on the instrument 

 

Data will begin to transfer from the instrument to the PC, and will 

appear in the data window of the Instrument Download Center.  If 

the data appears garbled, the wrong instrument type has been 

selected.  Select another instrument type and try again.  If data 

does not appear in the data window at all, verify that: 

 

 The instrument is connected to a valid serial port 

 All cables are securely connected 

 The message “Port Status:  On” appears in the status bar 

 There are no errors on the instrument 

 

Selecting A Serial Port 

Use the Serial Port option box to select the port to which the 

instrument is connected. 
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Selecting An Instrument 

Use the Instrument option box to select the model of Metal 

Samples instrument being downloaded.  This sets the appropriate 

communication parameters, which will be displayed in the status 

bar at the bottom of the window (“9600,N,8,1” for an MS1500 or 

MS4500E, or “2400,N,8,1” for an MS3500). 

 

Downloading Data 

To toggle the selected port on and off, click the Connect button.  

Toggling the port on and off will also clear the data window.  

 

Once a valid serial port and instrument have been selected, click 

the Connect button to turn the port on and enable the computer to 

receive data.  If a valid serial port has been selected, the status bar 

at the bottom of the window will display the message “Port Status:  

On”.  If an invalid serial port has been selected, an error message 

will appear, and the status bar will display the message “Port 

Status:  Off”.  If this happens, another serial port should be 

selected. 

 

Saving Data 

To save the data in the data window, click the Save button, or click 

Save in the File menu.  The data is comma-delimited ASCII text.  

It can be saved to a standard text (.txt) file, or it can be saved to a 

comma-separated values (.csv) file, which greatly simplifies the 

process of importing the data into some spreadsheet programs such 

as Excel®. 

 
Printing Data 

To print the contents of the data window, click the Print button, or 

click Print in the File menu.  A print dialog box will be displayed 

to allow printer selection and setup.  

 

Charting Data 

To chart the contents of the data window, click the Chart Data 

button, or click Chart Data in the File menu.  If the data has not 

yet been saved, the user will be prompted to do so before the 

charting process begins.  For more information on charting data, 

see the Data Analysis section. 
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Data Analysis 
 

The Data Analysis utility is a convenient tool for charting data 

from Metal Samples ER and LPR data logger instruments.  The 

Data Analysis utility can be opened from the Main Menu, or it can 

be opened directly from the Instrument Download Center. 

 

If the Data Analysis utility is opened from the Instrument 

Download Center, the contents of the data window will be loaded 

into the chart.  However, if the Data Analysis utility is opened 

directly from the Main Menu, a valid data file must be loaded.  The 

Select File box will open to allow selection of a data file. 

 

Loading A Data File 

After selecting a data file (or clicking the Chart Data button from 

the Instrument Download Center) a status window will display the 

progress of the file being opened, along with the Instrument Type, 

Probe Type, and Probe ID for the data file. 

 

 
 

Data Table 

After a file has been successfully loaded, the data will be displayed 

in the Data Table for review.  The Probe ID selection box allows 

the user to select which probe ID is displayed. 

 

 
 

By default, all data points will be included in the chart.  However, 

data points can be turned off, or excluded, from the chart.  If the 
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“Excluded” flag appears in the status column for a data point, that 

data point will not appear in the chart.  To toggle the 

exclude/include status of a data point, double-click the data point, 

or select the data point and click Exclude/Include in the Options 

menu. 
 

The data table allows the user to change the display units for Metal 

Loss and Corrosion Rate.  Alternate display units are accessed 

through the Options menu as shown below. 

 

 
 

Printing Data 

The data table can be printed by clicking Print in the Options 

menu.  A print dialog box will be displayed to allow printer 

selection and setup. 
 

Creating A Chart 

To chart the selected data, click the Chart Data button, or select 

Chart Data from the Options menu.  The chart will be displayed in 

a new window. 
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Printing A Chart 

A chart can be printed using the Print Chart option in the File 

menu.  A print dialog box will be displayed to allow printer 

selection and setup. 

 

Exporting A Chart 

A chart can be exported to other applications using the Copy Chart 

option in the File menu.  This will copy both the chart and the raw 

data to the Windows® Clipboard.  The chart can then be inserted 

into other applications using the Paste function.  Note:  In some 

applications, using the Paste function will insert the raw data 

instead of the chart.  In this case, use the Paste Special function, 

then select Picture to insert the chart. 

 

Chart Tools 

 Statistical Data 

The Statistical Data tab at the bottom of the Data Chart 

window will display a page with statistical information about 

the chart data.  If the Statistical Data page is visible, this 

information can be printed by clicking Print Statistical Data in 

the File menu. 

 

 
 Finding A Data Points Value 

While viewing the chart, the value of any data point can be 

determined by simply clicking it.  The value will be displayed 

in the charts tool-tip box (a small text box that is displayed 

near the mouse pointer).  If the tool-tip box does not appear 

immediately after clicking the data point, hold the mouse 

pointer stationary over the chart background for a moment. 

 

 The Tools Menu 

The Tools menu contains a collection of utilities for viewing 

and manipulating the chart.  The Tools menu can be accessed 

by clicking Tools on the menu bar, or by right-clicking 

anywhere on the chart. 

 

o Data Markers 

Show Data Markers toggles the data markers on and 

off. 
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o Mean Value 

Show Mean Value toggles the mean value line on and 

off. 

 

o Trend Line 

Show Trend Line toggles the trend line on and off. 

 

o Title/Footnote Setup 

Title/Footnote Setup displays a window that allows 

the chart title and footnotes to be toggled on and off, 

and to be modified. 

 

o Plot Setup 

Plot Setup displays a window that allows 

configuration of Y-axis scaling, and of the chart type. 

 

The Y-axis can be scaled to default values by 

checking the Auto Scaling option box.  The Y-axis 

can be scaled to manual values by un-checking the 

Auto Scaling box, then entering the desired values in 

the Minimum and Maximum fields. 

 

o Data Series Color 

Double-clicking on the data series will open the Data 

Series Color selection box.  This allows the user to 

select the brush color for the plot line.  The default 

color for the plot line is Blue. 

 

o Zoom In 

Zoom In allows a region of the chart to be enlarged so 

that it may be viewed in greater detail.  To enlarge a 

region of the chart, click on the two data points that 

define the left and right boundaries of the region. 

 

In zoom mode, the mouse pointer will change to a 

cross-hair.  When zoom mode ends, the mouse 

pointer will return to its normal state. 

 

To cancel zoom mode, click Cancel Zoom In from 

the Tools menu, or simply press the Esc key. 

 

o Zoom Out 

Zoom Out restores the initial view of the chart, which 

displays the full data set. 
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o Calculate Corrosion Rate 

If the chart contains ER data, the Calculate 

Corrosion Rate option will become available under 

the Tools menu.  This option allows the corrosion 

rate to be calculated between any two data points on 

the chart.  To calculate the corrosion rate click 

Calculate Corrosion Rate, then click two data points 

of interest. 
 

Once the two points have been selected the user can 

move and place the corrosion rate marker wherever 

they like on the plot.  To set the final location simply 

move the label as desired, and left-click to place it at 

that point.   
 

 
 

The corrosion rate between those two data points will 

be displayed, along with extension lines to the two 

selected points.  The user can place multiple 

corrosion rate values, and they can be placed above 

and below the data plot as needed. 

 

Note, for the software to calculate a corrosion rate, 

the second point must have a higher value than the 

first, and must be on a later date (at least one day 

elapsed.) 

 

In calculate mode, the mouse pointer will change to 

an arrow/question mark.  When calculate mode ends, 

the mouse pointer will return to its normal state.   

 

To cancel a calculation, click Cancel Calculate from 

the Tools menu, or simply press the Esc key. 
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 Moving Average 

The tool bar offers a slider that allows the user to apply a moving 

average to the dataset.  This is useful for smoothing noisy data.  In 

the illustration below, a moving average of 4 data points has been 

applied, and the resulting average can be seen in green. 

 

Corrosion rates can be calculated on the averaged data set as well 

as the original data set.  However, it is important to note that both 

points used for a corrosion rate calculation must be from the same 

data set. 

 

 
 
 Annotation Labels 

Users can place annotations labels on the plot to mark important 

events and changes.  To place a label click the Add Annotation 

Label button  on the toolbar.  A dialog box will open that allows 

the desired text to be entered.  Click OK, then place the text as 

desired. 

 

 
 

Labels can be relocated by single-clicking them, and then 

relocating them as desired. 
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Label text can be edited by double-clicking them. This will open 

the text edit box, where the text can be edited.  Click OK again to 

save changes, or click Cancel to discard changes. 

 

Labels can be deleted by right-clicking them.  The user will be 

prompted to confirm if they want to delete the label. 

 

Once labels have been placed on the plot, an annotation layer is 

created.  Use the Active Layer control to toggle between the 

annotation layer and the data layer, and to select and interact with 

items on each of those layers. 
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LPR Alloy Multiplier Worksheet 
 

The LPR Alloy Multiplier Worksheet simplifies the process of 

calculating alloy multipliers for use with the 2-Electrode LPR 

system. 

 

 
 

Calculating An Alloy 

To calculate an alloy multiplier, the alloy must be “built” by 

adding each of its elements to the Alloy Composition list.  An 

element is added to the list by selecting it from the drop-down 

menu, entering its percentage in the Percentage field, then clicking 

the Add button.  To add the remaining percentage to an element, 

select that element, then click the Balance button.  If it is necessary 

to remove an element from the list, highlight that element in the 

list, then click the Remove button. 

 

After all of the elements for an alloy have been entered, click the 

Calculate button to calculate the alloy multiplier.  The Alloy 

Multiplier will be displayed in the Calculation Results box, along 

with the Equivalent Weight and Density for the alloy.  If desired, 

an identification number or description can be entered into the 

UNS/Description field. 
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Saving A Worksheet 

The File menu offers two options for saving a worksheet. 

 

 Add to Data File 

Add to Data File can be used to save data from multiple 

worksheets as entries in a data file, which can be opened by 

spreadsheet programs such as Excel® or Quattro Pro®.  The 

Save As dialog box will be displayed to allow selection of a 

file name.  If an existing file name is selected, the data from 

the worksheet will be saved as a new entry in that data file.  If 

the file name specified does not exist, a new file will be 

created with that name, and the worksheet data will be saved 

as the first entry in the new file. 

 

 Save to Text File 

Save to Text File can be used to save an individual worksheet.  

The Save As dialog box will be displayed to allow selection of 

a file name and file location.  The worksheet will be saved 

using the file name and location specified, and can be opened 

using any text editor or word processor. 

 

Printing A Worksheet 

A worksheet can be printed using the Print option in the File 

menu.  A print dialog box will be displayed to allow printer 

selection and setup. 
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Corrosion Coupon Worksheet 
 

The Corrosion Coupon Worksheet is a simple, step-by-step method 

for calculating metal loss and corrosion rate from corrosion 

coupons. 

 

 
 

Calculating Corrosion Rate 

To calculate the corrosion rate of a coupon, enter the requested 

information in the Coupon Configuration and Exposure Data 

boxes, then click the Calculate button.  The calculated Surface 

Area, Total Exposure, Metal Loss, and Corrosion Rate will be 

displayed in the Results box.  Any comments or special 

information can be entered in the Comments field. 

 

Many standard Metal Samples coupons are listed in the Coupon 

Type menu.  When using one of these coupons, its dimensions can 

be entered automatically by selecting it from the list.  If the coupon 

being calculated is not found in the list, select Other, then enter the 

coupon dimensions manually. 

 

To reset the worksheet, click the Clear button, or click Clear in the 

Project menu. 

 

Unit Selection 

The measurement units for Density, Dimensions, Metal 

Loss/Corrosion Rate, and Weight can all be configured 

independently using the Units option in the Project menu. 
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Saving A Worksheet 

The File menu offers three options for saving a worksheet. 

 

 Add To Data File 

Add to Data File can be used to save data from multiple 

worksheets as entries in a data file, which can be opened by 

spreadsheet programs such as Excel® or Quattro Pro®.  The 

Save As dialog box will be displayed to allow selection of a 

file name.  If an existing file name is selected, the data from 

the worksheet will be saved as a new entry in that data file.  If 

the file name specified does not exist, a new file will be 

created with that name, and the worksheet data will be saved 

as the first entry in the new file. 

 

 Save To Text File 

Save to Text File can be used to save an individual worksheet 

as a text file.  The Save As dialog box will be displayed to 

allow selection of a file name and file location.  The 

worksheet will be saved using the file name and location 

specified, and can be opened using any standard text editor or 

word processor. 

 

 Start Batch Job 

Start Batch Job can be used to save a batch of coupons to a 

common data file.  Start Batch Job is similar to Add to Data 

File, but unlike Add to Data File, each coupon is saved 

automatically upon calculation.  For more information read the 

Batch Jobs topic below. 

 

Printing A Worksheet 

A worksheet can be printed using the Print button, or the Print 

option in the File menu.  A print dialog box will be displayed to 

allow printer selection and setup.  

 

Batch Jobs 

Start Batch Job (under the File menu) allows you to begin a batch 

job for saving multiple coupons to a common data file.  The Save 

As dialog box will be displayed to allow selection of a data file.  If 

an existing file is selected, each coupon will be saved as a new 

entry in that data file.  If the file specified does not already exist, a 

new file will be created with that name and the coupon data will be 

saved to the new file. 

 

There are two batch job options that can be configured by the user.  

They are found under the Project menu. 
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 Auto-Increment Sequence# 

When this option is selected, the sequence number will be 

automatically incremented after each calculation.  This is 

useful when working with a batch of coupons that have 

consecutive sequence numbers. 

 

When this option is selected, the cursor will return to the 

Installation Date field after each calculation.  If Auto-

Increment Sequence# is not selected, the cursor will return to 

the Sequence# field after each calculation.  NOTE:  Auto-

Increment Sequence# will not work with alphanumeric 

sequence numbers. 

 

 Confirm Each Entry 

When this option is selected, the user will be prompted to 

confirm each calculation before it is added to the data file. 
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Support 
 

While every effort has been made to ensure this software product 

is free from defects, problems may still occur during its use.  If you 

do encounter a problem while using this product, follow these 

steps to resolve it. 

 

1.  Make sure your computer meets the System Requirements listed 

in the Setup section of this manual. 

 

2.  Visit the Metal Samples web site and search the FAQ's page 

(http://www.alspi.com/cdmsfaq.htm).  Your problem, and a 

solution, may already be posted there. 

 

3.  Visit the Metal Samples web site to see if there is a software 

update available.  Software updates, and a list of the problems they 

fix, will be posted at http://www.alspi.com/cdmsupdate.htm.  If an 

update is available, follow the directions on the web page to 

download and install it. 

 

4.  If your problem has not been addressed on the FAQ's page, or 

in a software update, contact Metal Samples for additional support. 

http://www.alspi.com/cdmsfaq.htm
http://www.alspi.com/cdmsupdate.htm
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Warranty 
 

THE CORROSION DATA MANAGEMENT SOFTWARE 

(SOFTWARE PRODUCT) IS PROVIDED "AS IS," WITHOUT 

WARRANTY OF ANY KIND. 

 

METAL SAMPLES CORROSION MONITORING SYSTEMS 

DISCLAIMS ALL OTHER WARRANTIES AND CONDITIONS, 

EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT 

LIMITED TO, IMPLIED WARRANTIES OF 

MERCHANTABILITY, FITNESS FOR A PARTICULAR 

PURPOSE, TITLE AND NON-INFRINGEMENT, WITH 

REGARD TO THE SOFTWARE PRODUCT, AND THE 

PROVISION OF OR FAILURE TO PROVIDE SUPPORT 

SERVICES. THIS LIMITED WARRANTY GIVES YOU 

SPECIFIC LEGAL RIGHTS. YOU MAY HAVE OTHERS, 

WHICH VARY FROM STATE/JURISDICTION TO 

STATE/JURISDICTION. 

 

IN NO EVENT SHALL METAL SAMPLES CORROSION 

MONITORING SYSTEMS BE LIABLE FOR ANY SPECIAL, 

INCIDENTAL, INDIRECT, OR CONSEQUENTIAL DAMAGES 

WHATSOEVER (INCLUDING, WITHOUT LIMITATION, 

DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS 

INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR 

ANY OTHER PECUNIARY LOSS) ARISING OUT OF THE 

USE OF OR INABILITY TO USE THE SOFTWARE PRODUCT 

OR THE PROVISION OF OR FAILURE TO PROVIDE 

SUPPORT SERVICES, EVEN IF METAL SAMPLES 

CORROSION MONITORING SYSTEMS HAS BEEN ADVISED 

OF THE POSSIBILITY OF SUCH DAMAGES. 
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License Agreement 
 
IMPORTANT--READ CAREFULLY: This End-User License Agreement is a legal 

agreement between you (either an individual or a single entity) and Metal Samples 
Corrosion Monitoring Systems for the Corrosion Data Management Software 

(SOFTWARE PRODUCT). By installing or otherwise using the SOFTWARE 

PRODUCT, you agree to be bound by the terms of this agreement.  If you do not 
agree to the terms of this agreement, do not install or use the SOFTWARE 

PRODUCT. 

 
SOFTWARE PRODUCT LICENSE 

 

The SOFTWARE PRODUCT is protected by copyright laws and international 
copyright treaties, as well as other intellectual property laws and treaties. The 

SOFTWARE PRODUCT is licensed, not sold. 

 

1. GRANT OF LICENSE. This agreement grants you the following rights: 

1.1 Software Product. Metal Samples Corrosion Monitoring 

Systems grants to you as an individual, a personal, nonexclusive license 
to use the SOFTWARE for the sole purposes of downloading and 

plotting corrosion data from data logger instruments purchased from 

Metal Samples Corrosion Monitoring Systems, and for calculating 
corrosion rate from corrosion coupons.  

1.2 Storage/Network Use. You may also store or install a copy of 

the SOFTWARE PRODUCT on a storage device, such as a network 
server, used only to install or run the SOFTWARE PRODUCT on your 

other computers over an internal network. 
1.3 You may not redistribute this SOFTWARE PRODUCT 

without prior permission from Metal Samples Corrosion Monitoring 

Systems. 
1.4 You may not sell this SOFTWARE PRODUCT. 

 

2. DESCRIPTION OF OTHER RIGHTS AND LIMITATIONS.  
2.1 Limitations on Reverse Engineering, Decompilation, and 

Disassembly. You may not reverse engineer, decompile, or disassemble 

the SOFTWARE PRODUCT. 
2.2 Rental. You may not rent, lease, or lend the SOFTWARE 

PRODUCT.  

2.3 Support Services. At their discretion, Metal Samples 
Corrosion Monitoring Systems may provide you with limited support 

services related to the SOFTWARE PRODUCT.  

2.4 Termination. Without prejudice to any other rights, Metal 
Samples Corrosion Monitoring Systems may terminate this agreement if 

you fail to comply with the terms and conditions of this agreement. In 

such event, you must destroy all copies of the SOFTWARE PRODUCT 

and all of its component parts. 

 

3. COPYRIGHT. All title and copyrights in and to the SOFTWARE 
PRODUCT are owned by Metal Samples Corrosion Monitoring Systems. The 

SOFTWARE PRODUCT is protected by copyright laws and international treaty 

provisions. Therefore, you must treat the SOFTWARE PRODUCT like any other 
copyrighted material.  

 

4. U.S. GOVERNMENT RESTRICTED RIGHTS. The SOFTWARE 
PRODUCT and documentation are provided with RESTRICTED RIGHTS. Use, 

duplication, or disclosure by the Government is subject to restrictions as set forth in 



21 

subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software 

clause at DFARS 252.227-7013 or subparagraphs (c)(1) and (2) of the Commercial 
Computer Software-Restricted Rights at 48 CFR 52.227-19, as applicable.  

 

5. EXPORT RESTRICTIONS. You agree that neither you nor your 
customers intend to or will, directly or indirectly, export or transmit the 

SOFTWARE PRODUCT to any country to which such export or transmission is 

restricted by any applicable U.S. regulation or statute, without the prior written 
consent, if required, of the Bureau of Export Administration of the U.S. Department 

of Commerce, or such other governmental entity as may have jurisdiction over such 

export or transmission. 


